In the first lesson, I introduced the OSPF stub areas. I also covered the stub area and totally stub area. Now we get to see the OSPF NSSA (Not So Stubby) area. Here’s the topology we will use:

ospf stub area

And here’s the configuration. We will turn OSPF Area 1 into a stub area:

R1(config)#router ospf 1
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config-router)#redistribute connected subnets
R2(config)#router ospf 1
R2(config-router)#area 1 stub
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0 
R2(config-router)#network 192.168.23.0 0.0.0.255 area 1
R3(config)#router ospf 1
R3(config-router)#area 1 stub
R3(config-router)#network 192.168.23.0 0.0.0.255 area 1

The loopback 0 interface of R1 is redistributed into OSPF. I did this to test the stub area since it blocks LSA type 5. This is what the routing table of R3 looks like now:

R3#show ip route ospf 
O IA 192.168.12.0/24 [110/2] via 192.168.23.2, 00:00:42, FastEthernet0/0
O*IA 0.0.0.0/0 [110/2] via 192.168.23.2, 00:00:42, FastEthernet0/0

When we look at R3, you’ll see network 192.168.12.0 /24 and a default route as inter-area (LSA Type 3). Now to demonstrate the NSSA, I will create a new loopback interface on R3:

R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#redistribute connected subnets

I’ll add a new loopback interface and try to redistribute it into OSPF on R3. Here’s what you’ll see:

R3# %OSPF-4-ASBR_WITHOUT_VALID_AREA: Router is currently an ASBR while having only one area which is a stub area

The stub and totally stub area block LSA Type 5, so it’s impossible to have an ASBR within these areas. Let me show you how the NSSA solves this problem:

R2(config)#router ospf 1
R2(config-router)#no area 1 stub
R2(config-router)#area 1 nssa
R3(config)#router ospf 1
R3(config-router)#no area 1 stub
R3(config-router)#area 1 nssa

We’ll convert area 1 into an NSSA area. What is different this time?

R3#show ip route ospf
O IA 192.168.12.0/24 [110/2] via 192.168.23.2, 00:00:44, FastEthernet0/0

First of all, you can see that it only allows inter-area routes. LSA Type 5 is blocked, but I also don’t see any default routes…you have to do this yourself for the NSSA area; otherwise, R3 will be unable to reach network 1.1.1.0 /24. Let’s add a default route:

R2(config)#router ospf 1
R2(config-router)#area 1 nssa default-information-originate

We’ll add the default route on R2. Be careful: I’m using a different command this time…area nssa default-information-originate. What does the routing table look like now?

R3#show ip route ospf
O IA 192.168.12.0/24 [110/2] via 192.168.23.2, 00:06:21, FastEthernet0/0
O*N2 0.0.0.0/0 [110/1] via 192.168.23.2, 00:00:54, FastEthernet0/0

Now we see a default route on R3. It shows up as an N2 route (OSPF NSSA External Type 2).

The reason I configured the NSSA area is so we could redistribute the loopback0 interface on R3 into OSPF. Did this work? Let’s find out:

R1#show ip route ospf 
     3.0.0.0/24 is subnetted, 1 subnets
O E2    3.3.3.0 [110/20] via 192.168.12.2, 00:07:25, FastEthernet0/0
O IA 192.168.23.0/24 [110/2] via 192.168.12.2, 00:07:41, FastEthernet0/0

There you go. We can see network 3.3.3.0 /24 as an external type 2 route on R1. That’s all there is to it!

Unit 1: Introduction to OSPF

Unit 2: OSPF Neighbor Adjacency

Unit 3: OSPF Network Types

Unit 4: OSPF Stub Areas

Unit 5: Advanced OSPF Topics