EIGRP Default Network Route
In this lesson we’ll take a look how we can configure a default route in EIGRP. Basically there are two methods how you can do this:
- Create a static route and advertise it into EIGRP.
- Flag an EIGRP route as the default network.
We will take a look at both methods. This is the topology we will use:
R1 and R2 are configured for EIGRP, R2 is connected to an ISP router. Behind the ISP is network 3.3.3.0 /24 that we can use to test our default route.
Configuration
Here’s the configuration of R1 and R2:
R1#show run | section eigrp
router eigrp 12
network 192.168.12.0
no auto-summary
R2#show run | section eigrp
router eigrp 12
network 192.168.12.0
no auto-summary
Nothing special, R1 and R2 are neighbors but that’s it.
Static Default Route
Let’s start with the first option, the static default route:
R2(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet 0/1
R2(config)#router eigrp 12
R2(config-router)#network 0.0.0.0
We configure the default route on R2 with FastEthernet 0/1 as the exit interface. In EIGRP we can use the network 0.0.0.0 command to advertise this. This might sound strange but it works, normally you can only use the network command to advertise networks on interfaces but EIGRP wil make an exception for this default route.
When I tested this I had to use the interface as the next hop instead of specifying the next hop IP address. Otherwise the default route won’t be advertised in EIGRP. Instead of using the network command you can also redistribute this network.
Let’s see what R1 thinks of this:
R1#show ip route eigrp | begin 0.0.0.0
Gateway of last resort is 192.168.12.2 to network 0.0.0.0
D* 0.0.0.0/0 [90/30720] via 192.168.12.2, 00:01:11, FastEthernet0/0
R1 has learned the default route.
- Configurations
- ISP
- R1
- R2
Want to take a look for yourself? Here you will find the final configuration of each device.
Let’s look at the other method. Let’s get rid of the default route now so we can try the other method:
R2(config)#router eigrp 12
R2(config-router)#no network 0.0.0.0
R2(config)#no ip route 0.0.0.0 0.0.0.0 FastEthernet 0/1
There we go…let’s continue!
IP Default Network
This one is a bit tricky, we can use the ip default-network command to tell other EIGRP routers that this is a network of “last resort”. This means that they can use it as a default route. We will advertise the network between R2 and ISP in EIGRP and configure it as the “default network”:
R2(config)#router eigrp 12
R2(config-router)#network 192.168.23.0
R2(config)#ip default-network 192.168.23.0
Above you can see that the ip default-network command is a global command, it’s not an EIGRP command. Let’s see what happens:
R2#show ip eigrp topology 192.168.23.0
IP-EIGRP (AS 12): Topology entry for 192.168.23.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
Routing Descriptor Blocks:
0.0.0.0 (FastEthernet0/1), from Connected, Send flag is 0x0
Composite metric is (281600/0), Route is Internal
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 1000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 0
Exterior flag is set
Above you can see that R2 has set the “exterior flag” for this network. Let’s see what R1 thinks of this:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.12.2 to network 192.168.23.0
C 192.168.12.0/24 is directly connected, FastEthernet0/0
D* 192.168.23.0/24 [90/307200] via 192.168.12.2, 00:00:07, FastEthernet0/0
Above you can see the * next to the “D” for this EIGRP entry. This means that this network is used as the default route. R1 will now use this entry as a default route.
Even though R2 advertises network 192.168.23.0 /24 as the default network, it won’t use it itself as a default route. We’ll have to configure a default route on R2:
R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.3
Let’s make sure the ISP has an entry for 192.168.12.0 /24 so that we can test traffic from R1 to ISP:
ISP(config)#ip route 192.168.12.0 255.255.255.0 192.168.23.2
Everything is now in place, let’s try a ping:
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/49/104 ms
There we go, our ping is working which proves that R1 is using 192.168.23.0 /24 as its default route.
Table of Content
Unit 2: EIGRP Neighbor Adjacency
Unit 4: EIGRP Advanced Features