EIGRP Named Mode Configuration

Since IOS 15, EIGRP has a new method of configuration called named mode EIGRP.  With the “classic” version of EIGRP that we used before IOS 15 we configured EIGRP globally and some other things (like authentication) on the interfaces. With named mode EIGRP, we do everything globally.

If you try to configure EIGRP on a IOS 15.x router you will see this:

R1(config)#router eigrp?
  <1-65535>  Autonomous System
  WORD       EIGRP Virtual-Instance Name

Instead of an AS number we can also choose a name. Let’s try this, I’ll use two routers for this demonstration:

EIGRP R1 R2

Let’s start with R1:

R1(config)#router eigrp MY_NAME
R1(config-router)#?
Router configuration commands:
  address-family  Enter Address Family command mode
  default         Set a command to its defaults
  exit            Exit from routing protocol configuration mode
  no              Negate a command or set its defaults
  service-family  Enter Service Family command mode
  shutdown        Shutdown this instance of EIGRP

The configuration is now done using an address-family. Let’s select it:

R1(config-router)#address-family ?
  ipv4  Address family IPv4
  ipv6  Address family IPv6

EIGRP named mode covers both IPv4 and IPv6. Let’s try IPv4:

R1(config-router)#address-family ipv4 autonomous-system 12

This is where I configure everything. For example advertising a network:

R1(config-router-af)#network 192.168.12.0

Everything that used to be configured on the interface is now under the same global configuration:

R1(config-router-af)#af-interface FastEthernet 0/0
R1(config-router-af-interface)#?
Address Family Interfaces configuration commands:
  authentication      authentication subcommands
  bandwidth-percent   Set percentage of bandwidth percentage limit
  bfd                 Enable Bidirectional Forwarding Detection
  dampening-change    Percent interface metric must change to cause update
  dampening-interval  Time in seconds to check interface metrics
  default             Set a command to its defaults
  exit-af-interface   Exit from Address Family Interface configuration mode
  hello-interval      Configures hello interval
  hold-time           Configures hold time
  next-hop-self       Configures EIGRP next-hop-self
  no                  Negate a command or set its defaults
  passive-interface   Suppress address updates on an interface
  shutdown            Disable Address-Family on interface
  split-horizon       Perform split horizon
  summary-address     Perform address summarization

Let’s try authentication:

R1(config-router-af-interface)#authentication mode md5
R1(config-router-af-interface)#authentication key-chain MY_CHAIN

Let’s create a key chain to finish the configuration:

R1(config)#key chain MY_CHAIN
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string PASSWORD

That takes care of the configuration on R1. Let’s configure R2 with the “classic” commands:

R2(config)#key chain MY_CHAIN
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string PASSWORD
R2(config)#router eigrp 12
R2(config-router)#network 192.168.12.0
R2(config)#interface FastEthernet 0/0
R2(config-if)#ip authentication key-chain eigrp 12 MY_CHAIN
R2(config-if)#ip authentication mode eigrp 12 md5

EIGRP is still the same, only the configuration commands have changed. Show commands are still the same:

R1#show ip eigrp neighbors
EIGRP-IPv4 VR(MY_NAME) Address-Family Neighbors for AS(12)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.2            Fa0/0             12 00:00:35    6   200  0  3

That’s all there is to EIGRP named mode. The protocol is still the same, only the configuration is a bit different.

Table of Content

Unit 1: Introduction to EIGRP

Unit 2: EIGRP Neighbor Adjacency

Unit 3: EIGRP Filtering

Unit 4: EIGRP Advanced Features